commit fe8d4d3ce664e54e869ec4422b1e5eea8e7d2307
parent 49696fad0d4949ae506153e81983525ba2cb7975
Author: Nick Econopouly <wry@mm.st>
Date: Fri, 5 Feb 2021 15:43:53 -0500
Update to latest version with fixed build process
Had to add temporary conflict with jami-gnome. Both packages provide
the 'jami' shell script (which chooses a client and launches
it). Waiting for a decision about this upstream.
Diffstat:
3 files changed, 15 insertions(+), 42 deletions(-)
diff --git a/.SRCINFO b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jami-client-qt-git
pkgdesc = A free and private communication platform (QT client)
- pkgver = r274.dc634fe
+ pkgver = r296.8caf659
pkgrel = 1
url = https://git.jami.net/savoirfairelinux/jami-client-qt
arch = x86_64
@@ -12,10 +12,10 @@ pkgbase = jami-client-qt-git
depends = libnm
depends = qrencode
provides = jami-client-qt
+ conflicts = jami-gnome-git
+ conflicts = jami-gnome
source = git+https://git.jami.net/savoirfairelinux/jami-client-qt.git
- source = 0001.patch
sha512sums = SKIP
- sha512sums = 2772ecf10cc20e9183957324507dfcb047119452feb4d9610d69fdc9a41bce837726b70ff6d40b1e2ecd35f9daa391d767543315ffc5941b5227cd5b2927c9e3
pkgname = jami-client-qt-git
diff --git a/0001.patch b/0001.patch
@@ -1,16 +0,0 @@
-diff --git a/jami-qt.pro b/jami-qt.pro
-index 57df532..5f89524 100644
---- a/jami-qt.pro
-+++ b/jami-qt.pro
-@@ -102,9 +102,9 @@ unix {
- INCLUDEPATH += $${LRC}/include/libringclient
- LIBDIR = $${LRC}/lib
- } else {
-- INCLUDEPATH += $${LRC}/src
-+ INCLUDEPATH += $${LRC}
- isEmpty(LRCBUILD) {
-- LIBDIR = $${LRC}/build
-+ LIBDIR = $${LRC}
- } else {
- LIBDIR = $${LRCBUILD}
- }
diff --git a/PKGBUILD b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Nick Econopouly <wry at mm dot st>
pkgname=jami-client-qt-git
-pkgver=r274.dc634fe
+pkgver=r296.8caf659
pkgrel=1
pkgdesc="A free and private communication platform (QT client)"
arch=('x86_64')
@@ -9,36 +9,25 @@ url="https://git.jami.net/savoirfairelinux/jami-client-qt"
license=('GPL3')
depends=('jami-daemon-git' 'libjamiclient-git' 'qt5-base' 'libnm' 'qrencode')
makedepends=('git' )
-source=("git+$url.git" '0001.patch' )
-sha512sums=(SKIP 2772ecf10cc20e9183957324507dfcb047119452feb4d9610d69fdc9a41bce837726b70ff6d40b1e2ecd35f9daa391d767543315ffc5941b5227cd5b2927c9e3 )
+conflicts=('jami-gnome-git' 'jami-gnome')
+source=("git+$url.git")
+sha512sums=(SKIP)
pkgver() {
cd $srcdir/jami-client-qt
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-# git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-prepare() {
- cd $srcdir/jami-client-qt
- git apply ../0001.patch
- mkdir -p build
}
build() {
- cd jami-client-qt/build
- /usr/bin/qmake-qt5 ../jami-qt.pro "LRC=/usr/include/libringclient"
- make -j4
+ cd jami-client-qt
+ mkdir -p build
+ cd build
+ # /usr is necessary for Arch; see https://archlinux.org/news/binaries-move-to-usrbin-requiring-update-intervention/
+ cmake .. -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr"
+ make -j`nproc` # -j`nproc` uses as many cores as possible to speed up the build
}
-
-# package() {
-# cd "$srcdir/${pkgname%-VCS}"
-# make DESTDIR="$pkgdir/" install
-# }
-
package() {
- cd jami-client-qt/build
- # make DESTDIR="${pkgdir}/" install # waiting on upstream fixes
- install -Dm755 ./jami-qt "$pkgdir/usr/bin/jami-qt"
- install -Dm644 ../License.rtf "$pkgdir/usr/share/licenses/jami-client-qt/LICENSE" # waiting on an upstream rename
+ cd jami-client-qt/build
+ make install
}