commit 694afc8587ed4043ddf9af2b92a6624db36fb8cf
parent 457a77d934b668da4f6cc3f19b18fd1c2eb45218
Author: Nick Econopouly <wry@mm.st>
Date: Fri, 22 Feb 2019 16:15:53 -0500
make nightly install to a temporary directory for the build, added instructions for users with the toolchain installed already
Diffstat:
2 files changed, 20 insertions(+), 8 deletions(-)
diff --git a/.SRCINFO b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tiny-irc-client-git
pkgdesc = A console IRC client
- pkgver = 0.4.0
+ pkgver = 0.4.3
pkgrel = 1
url = https://github.com/osa1/tiny
arch = x86_64
@@ -10,6 +10,8 @@ pkgbase = tiny-irc-client-git
depends = openssl
depends = dbus
provides = tiny
+ source = git+https://github.com/osa1/tiny
+ sha512sums = SKIP
pkgname = tiny-irc-client-git
diff --git a/PKGBUILD b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Nick Econopouly <wry at mm dot st>
pkgname=tiny-irc-client-git
-pkgver="0.4.0"
+pkgver="0.4.3"
pkgrel=1
pkgdesc="A console IRC client"
arch=('x86_64')
@@ -9,16 +9,27 @@ url="https://github.com/osa1/tiny"
license=('MIT')
depends=('openssl' 'dbus')
makedepends=('git' 'rust-nightly')
+source=(git+$url)
+sha512sums=(SKIP)
build() {
- return 0
+ # Installs the Rust nightly toolchain to a temporary
+ # directory. If you already have the toolchain installed,
+ # e.g. via the script at https://rustup.rs/ or another
+ # package, you can remove the rust-nightly dependancy and
+ # comment out the following three commands.
+
+ mkdir nightly
+ export RUSTUP_HOME=$(pwd)/nightly
+ rustup toolchain install nightly
+
+ # build tiny
+ cd tiny
+ cargo +nightly build --release
}
package() {
- git clone "$url.git"
cd tiny
- cargo +nightly build --release
install -Dm755 target/release/tiny "$pkgdir/usr/bin/tiny"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/tiny/LICENSE"
-
-}-
\ No newline at end of file
+}